Vulnerability feed
CVE and vendor PSIRT advisories from 13 sources, last 30 days. Updated hourly, last run
| Expand | Severity |
Score |
Advisory |
Title |
Source |
Flags |
Published |
|---|---|---|---|---|---|---|---|
| High | 8.7 | CVE-2026-116183 |
phpMyFAQ before 4.1.10 contains an object-level authorization bypass vulnerability that allows unauthenticated attackers to modify or delete any visitor question by supplying...
thorsten, phpMyFAQthorsten phpMyFAQ, phpMyFAQ
|
NVD | |||
|
CVE-2026-116183phpMyFAQ before 4.1.10 contains an object-level authorization bypass vulnerability that allows unauthenticated attackers to modify or delete any visitor question by supplying...
Executive summaryAn unauthenticated visitor can modify or delete any visitor-submitted question in phpMyFAQ versions before 4.1.10 (the advisory lists affected versions as up to and including 4.2.0-beta). The advisory rates it High at CVSS 7.5 under the default configuration, and Critical at 9.1 when the option to delete open questions after answering is enabled. The advisory recommends upgrading to 4.1.10, which is listed as the patched version. Technical summaryThe flaw is an object-level authorization bypass (CWE-639) in POST /api/faq/create, where the client-supplied openQuestionID is cast to an integer and used directly as the key for UPDATE or DELETE queries on the faqquestions table, with no ownership, visibility, or permission check. Exploitation requires no account or CSRF token, only solving the graphical CAPTCHA, and the advisory states no user interaction is needed. With records.enableDeleteQuestion false (the shipped default), the attacker can rewrite a question's category and answer link (CVSS 7.5, integrity impact only); with it true, the question is permanently deleted (CVSS 9.1). The advisory lists the affected versions as <= 4.2.0-beta and the patched version as 4.1.10. Workarounds are not stated beyond the suggested code fix, and no detection guidance is given. No CVE ID is assigned in the advisory (it says 'No known CVE'). Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-9m55-g84r-x6v7 Impact if exploitedConfidentialityNone IntegrityHigh AvailabilityNone
How it is exploited
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||
| Medium | 5.3 | CVE-2026-116182 |
phpMyFAQ before 4.1.10 contains a server-side request forgery vulnerability in the PDF export feature that fetches external images referenced in FAQ answers
thorsten, phpMyFAQthorsten phpMyFAQ, phpMyFAQ
|
NVD | |||
|
CVE-2026-116182phpMyFAQ before 4.1.10 contains a server-side request forgery vulnerability in the PDF export feature that fetches external images referenced in FAQ answers
Executive summaryphpMyFAQ versions before 4.1.10 contain a server-side request forgery flaw in the PDF export feature, which can make the server fetch external images referenced in FAQ answers. The advisory rates it Moderate with a CVSS overall score of 5.0, and the fix is to update to version 4.1.10. Technical summaryThe flaw is server-side request forgery in the PDF export feature, which fetches image URLs in FAQ answers during PDF generation; in the tested setup a loopback-only HTTP service was requested and its response embedded in the PDF. Exploitation requires that localhost be listed in records.allowedMediaHosts and that an attacker can create or modify FAQ content, and the advisory states the full chain was not proven to be achievable by an entirely unauthenticated attacker. Affected versions are stated as <= 4.1.9 and the patched version as 4.1.10. The advisory does not state a workaround, and the CVSS vector given is CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N. No CVE identifier is listed (the advisory reports 'No known CVE'), and no detection guidance beyond the proof-of-concept steps is stated. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-8wmv-9c4g-p5mg Impact if exploitedConfidentialityLow IntegrityNone AvailabilityNone
How it is exploited
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||