Vulnerability feed
CVE and vendor PSIRT advisories from 13 sources, last 30 days. Updated hourly, last run
| Expand | Severity |
Score |
Advisory |
Title |
Source |
Flags |
Published |
|---|---|---|---|---|---|---|---|
| High | 8.4 | CVE-2026-115414 |
OS command injection in the Terraform hook in AWS SAM CLI before 1.166.2 might allow an actor who can influence the Terraform configuration or plan file consumed by a build to...
AWSaws-sam-cli
|
NVD | |||
|
CVE-2026-115414OS command injection in the Terraform hook in AWS SAM CLI before 1.166.2 might allow an actor who can influence the Terraform configuration or plan file consumed by a build to...
Executive summaryA flaw in the Terraform hook of AWS SAM CLI, a tool for building serverless applications, could let an attacker run arbitrary commands on the machine performing a build. The advisory rates it as important and says it requires attention. AWS recommends upgrading to version v1.166.2 or later, and reviewing that Terraform configuration and plan files come only from trusted sources. Technical summaryThe flaw is an OS command injection in the Terraform hook (sam build --hook-name terraform), where a Terraform resource address is interpolated into a generated Makefile recipe without fully neutralizing shell metacharacters. An attacker who can influence the Terraform configuration or plan file consumed by a build could execute commands as the build user on the build host. Impacted versions are stated as >=1.63.0, <=1.166.1, and the fixed version is v1.166.2. The advisory's workaround is to use only trusted Terraform configuration and plan files and audit third-party modules and shared repositories, and it says upgrading is the recommended remediation. No CVSS score, exploitation status, or specific detection guidance is stated. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from aws.amazon.com/security/security-bulletins/2026-145-aws Impact if exploitedConfidentialityHigh IntegrityHigh AvailabilityHigh
How it is exploited
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||