Vulnerability feed
CVE and vendor PSIRT advisories from 13 sources, last 30 days. Updated hourly, last run
| Expand | Severity |
Score |
Advisory |
Title |
Source |
Flags |
Published |
|---|---|---|---|---|---|---|---|
| High | 8.2 | CVE-2026-115417 |
Memory allocation with excessive size value in the MQTT 3.1.1 compatibility adapter in AWS aws-c-mqtt before 0.16.2 might allow a remote actor to cause a denial of service of...
AWSaws-c-mqtt, AWS IoT Device SDK for C++ v2
|
NVD | |||
|
CVE-2026-115417Memory allocation with excessive size value in the MQTT 3.1.1 compatibility adapter in AWS aws-c-mqtt before 0.16.2 might allow a remote actor to cause a denial of service of...
Executive summaryA memory allocation flaw in the MQTT 3.1.1 compatibility adapter of aws-c-mqtt, a messaging library distributed by AWS and bundled in the AWS IoT Device SDK for C++ v2, can let a remote party crash a client process. The advisory describes this as a denial of service issue and does not state a numeric severity score. AWS recommends upgrading to aws-c-mqtt v0.16.2 or later. Technical summaryThe flaw is a memory allocation with excessive size value (CWE-789) in the MQTT 3.1.1 compatibility adapter, which could let a remote actor cause a denial of service of the client process under certain conditions. Affected versions are stated as greater than or equal to 0.9.1 and less than 0.16.2. The fixed version is v0.16.2. The advisory says upgrading is the complete remediation. Workarounds given are to connect only to trusted MQTT brokers such as AWS IoT Core, to use TLS to prevent on-path tampering of broker responses, and to avoid the MQTT 3.1.1 compatibility adapter where feasible. The specific preconditions and exploitation details are not stated, and no detection guidance is provided. Whether the issue is exploited in the wild is not stated, and no CVSS score is given. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from aws.amazon.com/security/security-bulletins/2026-147-aws Impact if exploitedConfidentialityNone IntegrityNone AvailabilityHigh
How it is exploited
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||