Vulnerability feed
CVE and vendor PSIRT advisories from 13 sources, last 30 days. Updated hourly, last run
| Expand | Severity |
Score |
Advisory |
Title |
Source |
Flags |
Published |
|---|---|---|---|---|---|---|---|
| High | 8.6 | CVE-2026-58497 |
Uni-CLI gives people and agents one command interface for websites, browsers, desktop applications, local tools, and MCP
olo-dot-io, ZenAlexaolo-dot-io Uni-CLI, ZenAlexa @zenalexa/unicli
|
NVD | |||
|
CVE-2026-58497Uni-CLI gives people and agents one command interface for websites, browsers, desktop applications, local tools, and MCP
Executive summaryUni-CLI, a command interface tool for websites, browsers, desktop applications, and MCP, has a flaw in its legacy HTTP MCP transport that let a malicious web page reach a local Uni-CLI server when the user had started that transport. The advisory rates the issue High severity. The vendor recommends upgrading to version 0.225.2 or later, or avoiding browser-originated traffic to the legacy HTTP MCP transport until the upgrade is possible. Technical summaryThe weakness is an origin validation error (CWE-346) combined with cross-site request forgery (CWE-352). The legacy stateless HTTP MCP path on loopback did not check browser Origin headers before routing, so a web page could send a CORS simple POST with text/plain content to the local /mcp endpoint and drive tools/call requests. The precondition is that the user has started the local MCP HTTP transport. Affected versions are stated as less than 0.225.2, and the patched version is 0.225.2, which moves the Origin policy into a shared guard and rejects non-loopback browser Origins with HTTP 403. The advisory states the workaround as avoiding exposure of the legacy HTTP transport to browser traffic and using stdio or Streamable HTTP instead. No detection guidance and no CVSS score are stated, and exploitation in the wild is not stated. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from github.com/olo-dot-io/Uni-CLI/security/…/GHSA-v3f4-w7r7-v3hm Impact if exploitedConfidentialityHigh IntegrityHigh AvailabilityNone
How it is exploited
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X Affectsolo-dot-ioZenAlexaolo-dot-io Uni-CLIZenAlexa @zenalexa/unicli
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||