Vulnerability feed
CVE and vendor PSIRT advisories from 13 sources, last 30 days. Updated hourly, last run
| Expand | Severity |
Score |
Advisory |
Title |
Source |
Flags |
Published |
|---|---|---|---|---|---|---|---|
| High | 8.7 | CVE-2026-116177 |
vLLM from 0.10.2 before 0.25.0 contains an uncontrolled resource consumption vulnerability that allows unauthenticated attackers to exhaust memory because the Nemotron-VL...
vllm-project, Vllm, Pillowvllm-project vllm, vLLM, Pillow
|
NVD | |||
|
CVE-2026-116177vLLM from 0.10.2 before 0.25.0 contains an uncontrolled resource consumption vulnerability that allows unauthenticated attackers to exhaust memory because the Nemotron-VL...
Executive summaryvLLM, an open-source system for serving large language models, has a flaw in its Nemotron-VL image processors that lets an unauthenticated remote user exhaust server memory and deny service to other users on the same instance. The advisory rates the issue High, and the fix is to upgrade to vLLM 0.25.0 or later. Technical summaryThe weakness is CWE-400, uncontrolled resource consumption. Two Nemotron-VL processor modules set Pillow's Image.MAX_IMAGE_PIXELS to None at import time, which disables Pillow's decompression-bomb guard for the whole process. An unauthenticated caller who can reach /v1/chat/completions on an instance that has imported either processor can submit a crafted image that decompresses to a very large size, potentially causing the worker to be killed by the out-of-memory handler. Affected versions are listed as 0.10.2 before 0.25.0 in the NVD description and as <= 0.8.5 in the GitHub advisory, which the advisory does not reconcile; the patched version is stated as 0.25.0 or later. The fix in PR #47010 removes the module-level assignments and adds a decoded pixel-count limit configurable through VLLM_MAX_IMAGE_PIXELS. No workaround beyond upgrading is stated, and no detection guidance is stated. No CVSS score is stated, and the advisory gives severity as High. No known CVE ID is listed in the GitHub text, and exploitation in the wild is not stated. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from github.com/vllm-project/vllm/security/a…/GHSA-mm38-5g96-7j6x Impact if exploitedConfidentialityNone IntegrityNone AvailabilityHigh
How it is exploited
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||