Vulnerability feed
CVE and vendor PSIRT advisories from 13 sources, last 30 days. Updated hourly, last run
| Expand | Severity |
Score |
Advisory |
Title |
Source |
Flags |
Published |
|---|---|---|---|---|---|---|---|
| High | 7.1 | CVE-2026-114659 |
Grav Flex Objects plugin 1.4.0 before 1.4.17 contains an authorization bypass because its generic /api/v1/flex-objects/pages API routes check only directory-level admin.pages...
getgrav, Gravgetgrav grav-plugin-flex-objects, Grav Flex Objects plugin, Grav API plugin
|
NVD | |||
|
CVE-2026-114659Grav Flex Objects plugin 1.4.0 before 1.4.17 contains an authorization bypass because its generic /api/v1/flex-objects/pages API routes check only directory-level admin.pages...
Executive summaryA flaw in the Flex Objects plugin for the Grav content platform lets signed-in, non-super accounts with API access read, change, or delete pages they should be blocked from. The advisory rates it Moderate and says the fix is to update Flex Objects to 1.4.17 or, if that is not possible right away, to remove the affected admin permissions or API access from non-super accounts. Technical summaryThis is an authorization bypass (CWE-863, with CWE-424 alternate path) in the generic /api/v1/flex-objects/pages routes, which check only directory-level admin.pages permissions and skip the per-page api.pages.read and api.pages.write checks and page permissions rules that the Pages API enforces. The attacker needs an authenticated account with api.access plus admin.pages or admin.configuration.pages, and the advisory says it is not a super user account. Affected versions are Flex Objects >= 1.4.0, < 1.4.17 (1.4.0 through 1.4.16), with the fix in 1.4.17. The advisory states that the pages directory is enabled by default and that sites using API plugin 1.0.16 or later are affected when relying on page-level permissions rules. Workarounds are stated: remove admin.pages and admin.configuration.pages from non-super accounts and groups, or remove api.access from accounts that do not need it. The advisory does not state a CVE ID (it says 'No known CVE'), a CVSS score, whether the issue is exploited in the wild, or specific detection guidance. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from github.com/getgrav/grav/security/adviso…/GHSA-2pvc-r9gj-mcpf Impact if exploitedConfidentialityHigh IntegrityNone AvailabilityNone
How it is exploited
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X AffectsgetgravGravgetgrav grav-plugin-flex-objectsGrav Flex Objects pluginGrav API plugin
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||