Vulnerability feed
CVE and vendor PSIRT advisories from 13 sources, last 30 days. Updated hourly, last run
| Expand | Severity |
Score |
Advisory |
Title |
Source |
Flags |
Published |
|---|---|---|---|---|---|---|---|
| High | 8.7 | CVE-2026-116019 |
Grav 2.0.15 before 2.2.13 contains an allowlist bypass vulnerability that allows page editors to invoke arbitrary public static methods by relocating data-*@ directives with...
getgrav, Gravgetgrav grav, Grav
|
NVD | |||
|
CVE-2026-116019Grav 2.0.15 before 2.2.13 contains an allowlist bypass vulnerability that allows page editors to invoke arbitrary public static methods by relocating data-*@ directives with...
Executive summaryThe advisory says Grav CMS versions from 2.0.15 before 2.2.13 contain a flaw that lets users with page editing rights run arbitrary public static methods through blueprint directives. The text does not state a severity score. The advisory text does not state a vendor recommendation beyond the fix version shown in the description, so upgrading to 2.2.13 or later is the implied remedy. Technical summaryThe flaw is an allowlist bypass in Grav's handling of data-*@ blueprint directives, which lets a page editor invoke arbitrary public static methods by relocating directives. The advisory excerpt is a source code listing of Blueprint.php with comments describing a fix, and it shows the allowlist and provenance checks that address the issue. The attack precondition is page editor access, and the excerpt does not state a CVSS score, exploitation status, or detection guidance. The affected range is stated as 2.0.15 before 2.2.13, and the fixed version is 2.2.13 as written in the description. Workarounds are not stated. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from github.com/getgrav/grav/blob/2.2.12/sys…n/Data/Blueprint.php Impact if exploitedConfidentialityHigh IntegrityHigh AvailabilityHigh
How it is exploited
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||
| High | 7.1 | CVE-2026-114659 |
Grav Flex Objects plugin 1.4.0 before 1.4.17 contains an authorization bypass because its generic /api/v1/flex-objects/pages API routes check only directory-level admin.pages...
getgrav, Gravgetgrav grav-plugin-flex-objects, Grav Flex Objects plugin, Grav API plugin
|
NVD | |||
|
CVE-2026-114659Grav Flex Objects plugin 1.4.0 before 1.4.17 contains an authorization bypass because its generic /api/v1/flex-objects/pages API routes check only directory-level admin.pages...
Executive summaryA flaw in the Flex Objects plugin for the Grav content platform lets signed-in, non-super accounts with API access read, change, or delete pages they should be blocked from. The advisory rates it Moderate and says the fix is to update Flex Objects to 1.4.17 or, if that is not possible right away, to remove the affected admin permissions or API access from non-super accounts. Technical summaryThis is an authorization bypass (CWE-863, with CWE-424 alternate path) in the generic /api/v1/flex-objects/pages routes, which check only directory-level admin.pages permissions and skip the per-page api.pages.read and api.pages.write checks and page permissions rules that the Pages API enforces. The attacker needs an authenticated account with api.access plus admin.pages or admin.configuration.pages, and the advisory says it is not a super user account. Affected versions are Flex Objects >= 1.4.0, < 1.4.17 (1.4.0 through 1.4.16), with the fix in 1.4.17. The advisory states that the pages directory is enabled by default and that sites using API plugin 1.0.16 or later are affected when relying on page-level permissions rules. Workarounds are stated: remove admin.pages and admin.configuration.pages from non-super accounts and groups, or remove api.access from accounts that do not need it. The advisory does not state a CVE ID (it says 'No known CVE'), a CVSS score, whether the issue is exploited in the wild, or specific detection guidance. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from github.com/getgrav/grav/security/adviso…/GHSA-2pvc-r9gj-mcpf Impact if exploitedConfidentialityHigh IntegrityNone AvailabilityNone
How it is exploited
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X AffectsgetgravGravgetgrav grav-plugin-flex-objectsGrav Flex Objects pluginGrav API plugin
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||
| High | 8.7 | CVE-2026-114658 |
Grav Login plugin from 3.6.0 before 3.9.13 contains a missing authorization vulnerability in the login.invite task that allows page authors to obtain super user accounts
getgrav, Gravgetgrav grav-plugin-login, Grav Login plugin
|
NVD | |||
|
CVE-2026-114658Grav Login plugin from 3.6.0 before 3.9.13 contains a missing authorization vulnerability in the login.invite task that allows page authors to obtain super user accounts
Executive summaryThe Grav Login plugin, versions 3.6.0 through 3.9.12, has a flaw that lets a page author create a super user account through a login invitation form. The advisory rates it High severity and says the fix is in Login 3.9.13, which the vendor recommends installing. Technical summaryThis is a missing authorization issue (CWE-862, with related CWE-269) in the login.invite task, where Controller::taskInvite() only checked that a form was active on the page and did not check the sender. The task copied the access level from the page's form.meta.invite.account frontmatter into the invitation with no cap, so a page author can grant super access and anyone who can load the page can submit it without signing in. Affected versions are stated as >= 3.6.0, < 3.9.13 (Login 3.6.0 through 3.9.12), and the patched version is 3.9.13. The advisory states no workaround beyond the fix; it notes that sites restricting the invitation page with access: admin.login should be aware the sender now needs an account management permission. No CVE ID is assigned per the advisory, and no exploitation in the wild or CVSS score is stated. Detection guidance is not stated. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from github.com/getgrav/grav/security/adviso…/GHSA-j8jx-ccrg-m7h2 Impact if exploitedConfidentialityHigh IntegrityHigh AvailabilityHigh
How it is exploited
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||