Vulnerability feed
CVE and vendor PSIRT advisories from 13 sources, last 30 days. Updated hourly, last run
| Expand | Severity |
Score |
Advisory |
Title |
Source |
Flags |
Published |
|---|---|---|---|---|---|---|---|
| Medium | 6.3 | CVE-2026-115751 |
Agentfront mcp-from-openapi from 2.2.0 before 2.9.0 contains a server-side request forgery vulnerability that allows attackers to bypass the ssrf.blockedHosts denylist using...
agentfrontagentfront mcp-from-openapi
|
NVD | |||
|
CVE-2026-115751Agentfront mcp-from-openapi from 2.2.0 before 2.9.0 contains a server-side request forgery vulnerability that allows attackers to bypass the ssrf.blockedHosts denylist using...
Executive summaryThe advisory says Agentfront mcp-from-openapi versions from 2.2.0 before 2.9.0 contain a server-side request forgery flaw that lets attackers bypass the ssrf.blockedHosts denylist. The advisory text is truncated, so its stated severity, exploitation status, and full impact are not stated. The visible material is mainly a diff of documentation and tests showing fixes for hostname normalization, IPv6 transition addresses, and header handling on redirects; the advisory does not explicitly say what the vendor recommends beyond the fix in version 2.9.0. Technical summaryThe flaw is a server-side request forgery issue in which blockedHosts checks could be bypassed, likely through hostname variants such as trailing root dots or case differences, and through IPv6 forms that embed IPv4 addresses such as NAT64, 6to4, and IPv4-compatible addresses. The affected range is stated as from 2.2.0 before 2.9.0. The attack vector and required privileges are not stated in the visible text. The diff also shows caller headers being forwarded across redirects, which the change now restricts to the spec origin. No workaround is explicitly stated in the advisory, though the documentation notes that for untrusted input, allowedHosts should be combined with network egress controls. CVSS score, exploitation in the wild, and detection guidance are not stated. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from github.com/agentfront/mcp-from-openapi/…23490ab244343eb5fc44 Impact if exploitedConfidentialityLow IntegrityNone AvailabilityNone
How it is exploited
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||
| Medium | 6.3 | CVE-2026-115750 |
mcp-from-openapi from 2.5.0 before 2.9.0 contains a credential exposure vulnerability that allows attackers to capture Authorization and Cookie headers because safeFetch()...
agentfront, mcp-from-openapiagentfront mcp-from-openapi, mcp-from-openapi
|
NVD | |||
|
CVE-2026-115750mcp-from-openapi from 2.5.0 before 2.9.0 contains a credential exposure vulnerability that allows attackers to capture Authorization and Cookie headers because safeFetch()...
Executive summaryThe advisory says mcp-from-openapi versions from 2.5.0 before 2.9.0 can expose credentials, specifically Authorization and Cookie headers, to attackers. The advisory text shown is truncated and includes a diff of documentation and test changes, so the full severity rating is not stated. The advisory does not clearly state a vendor recommendation beyond the code and documentation changes shown. Technical summaryThe advisory describes a credential exposure flaw in mcp-from-openapi from 2.5.0 before 2.9.0, where Authorization and Cookie headers can be captured because safeFetch() forwards caller headers across redirects. The shown diff indicates that caller headers are now dropped once a redirect leaves the original origin, and that hostname matching for allowedHosts and blockedHosts is normalized. The diff also adds SSRF checks for IPv6 transition addresses and trailing-dot hostnames. The advisory text is truncated, so CVSS score, attack preconditions in full, workarounds, and detection guidance are not stated. The fixed version is stated as 2.9.0 only as the upper bound of the affected range. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from github.com/agentfront/mcp-from-openapi/…23490ab244343eb5fc44 Impact if exploitedConfidentialityLow IntegrityNone AvailabilityNone
How it is exploited
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X Affectsagentfrontmcp-from-openapiagentfront mcp-from-openapimcp-from-openapi
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||