Vulnerability feed
CVE and vendor PSIRT advisories from 13 sources, last 30 days. Updated hourly, last run
| Expand | Severity |
Score |
Advisory |
Title |
Source |
Flags |
Published |
|---|---|---|---|---|---|---|---|
| High | 8.8 | CVE-2026-116176 |
vLLM from 0.9.2 before 0.24.0 contains a server-side request forgery vulnerability that allows API callers to force outbound connections by embedding a decode address in the...
vllm-project, Vllmvllm-project vllm, vLLM, Vllm P2pNcclConnector
|
NVD | |||
|
CVE-2026-116176vLLM from 0.9.2 before 0.24.0 contains a server-side request forgery vulnerability that allows API callers to force outbound connections by embedding a decode address in the...
Executive summaryThe advisory says vLLM versions from 0.9.2 before 0.24.0 contain a server-side request forgery flaw that lets an API caller make the server open outbound connections and leak key-value cache data from requests processed by a prefill worker using the P2pNcclConnector. It is rated High severity. The recommended fix is to upgrade to vLLM 0.24.0, which removes the affected connector. Technical summaryThe flaw is classified as CWE-918 server-side request forgery. The OpenAIServing._base_request_id function copies the X-Request-Id HTTP header into the request_id without validation, and P2pNcclConnector.parse_request_id extracts an arbitrary host and port from it using a permissive regex, letting the caller force outbound ZMQ connections and NCCL communicator setup to an attacker-chosen host. The advisory states the affected range as >= 0.9.2, < 0.24.0 when using P2pNcclConnector, with the patched version 0.24.0. The precondition is a prefill worker configured with a kv_producer role and the P2pNcclConnector, and a valid API key or no key if --api-key is unset. PR #44854 removed the affected connector, and the advisory also describes a proposed fix of stripping the header and adding a CIDR or hostname allow-list. The advisory does not state any detection guidance or exploitation in the wild, and no CVSS score is stated beyond the High severity rating. No CVE identifier is given (it says 'No known CVE'). Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from https://github.com/vllm-project/vllm/security/advisories/GHSA-vfp2-c8pq-v6h6 Impact if exploitedConfidentialityHigh IntegrityNone AvailabilityLow
How it is exploited
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||