Vulnerability feed
CVE and vendor PSIRT advisories from 13 sources, last 30 days. Updated hourly, last run
| Expand | Severity |
Score |
Advisory |
Title |
Source |
Flags |
Published |
|---|---|---|---|---|---|---|---|
| High | 7.1 | CVE-2026-115807 |
The User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor plugin for WordPress is vulnerable to Limited Privilege Escalation in all...
Cozmoslabs, WordPress, User Profile BuilderCozmoslabs User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor, User Profile Builder, WordPress
|
NVD | |||
|
CVE-2026-115807The User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role Editor plugin for WordPress is vulnerable to Limited Privilege Escalation in all...
Executive summaryThe User Profile Builder plugin for WordPress contains a flaw that lets users with Author-level access and above create new accounts with higher-privilege roles such as Editor. The advisory describes this as a limited privilege escalation affecting all versions up to and including 4.0.3. The advisory does not state a severity rating or a vendor fix recommendation. Technical summaryThe flaw is a privilege escalation caused by missing server-side authorization: the Gutenberg Register block passes an attacker-controlled Assigned Role attribute into the [wppb-register] shortcode. The role guard only downgrades roles holding manage_options or remove_users, so roles such as Editor are not restricted. Exploitation requires an authenticated attacker with Author-level access or higher. Affected versions are stated as all versions up to and including 4.0.3, and a fixed version is not stated. A CVSS score, workarounds, and detection guidance are not stated in the advisory. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Impact if exploitedConfidentialityLow IntegrityHigh AvailabilityNone
How it is exploited
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N AffectsCozmoslabsWordPressUser Profile BuilderCozmoslabs User Profile Builder – Beautiful User Registration Forms, User Profiles & User Role EditorUser Profile BuilderWordPress
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||
| High | 7.2 | CVE-2026-111982 |
The User Profile Builder WordPress plugin before 4.0.5 does not verify that a user is authorized to edit the specific account selected on its front-end Edit Profile form,...
User Profile BuilderUser Profile Builder profile-builder
|
NVD | |||
|
CVE-2026-111982The User Profile Builder WordPress plugin before 4.0.5 does not verify that a user is authorized to edit the specific account selected on its front-end Edit Profile form,...
Executive summaryThe User Profile Builder WordPress plugin is affected by a flaw that lets a user edit accounts they are not authorized to change, which can lead to privilege escalation. The advisory rates it high severity with a CVSS score of 7.2. The fix is to update the plugin to version 4.0.5 or later. Technical summaryThe flaw is classified as privilege escalation (CWE-269, improper privilege management) and falls under OWASP A2, Broken Authentication and Session Management. The plugin does not verify that the current user is authorized to edit the specific account selected on its front-end Edit Profile form. The advisory states the affected versions as before 4.0.5 and the fixed version as 4.0.5. The attack vector, required privileges, and user interaction are not stated in the excerpt provided. No workaround is stated, and no detection guidance or evidence of exploitation in the wild is stated. The advisory text is truncated, so further details may be missing. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from wpscan.com/vulnerability/b7d1fd86-3927-…f2-88ed-46401e347320 Impact if exploitedConfidentialityHigh IntegrityHigh AvailabilityHigh
How it is exploited
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||
| Medium | 6.8 | CVE-2026-111966 |
The User Profile Builder WordPress plugin before 4.0.5 does not sanitise and escape one of its shortcode attributes before outputting it back in a redirect message, which...
User Profile BuilderUser Profile Builder
|
NVD | |||
|
CVE-2026-111966The User Profile Builder WordPress plugin before 4.0.5 does not sanitise and escape one of its shortcode attributes before outputting it back in a redirect message, which...
Executive summaryThe User Profile Builder WordPress plugin is affected by a cross-site scripting flaw in versions before 4.0.5. The advisory rates it medium severity with a CVSS score of 6.8, and the fix is to update the plugin to version 4.0.5 or later. Technical summaryThe flaw is a cross-site scripting (XSS, CWE-79) issue in which one shortcode attribute is neither sanitised nor escaped before being output back in a redirect message. The advisory describes the affected versions as before 4.0.5 and the fixed version as 4.0.5. Attack vector, required privileges, and user interaction are not stated in the advisory. Workarounds are not stated. Detection guidance is not stated. The advisory's other entries list unrelated plugins and do not describe this flaw. The CVSS vector string is not given; only the score of 6.8 (medium) is stated. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from wpscan.com/vulnerability/26983c21-09d2-…1f-b62f-1270b335dfcd Impact if exploitedConfidentialityHigh IntegrityHigh AvailabilityHigh
How it is exploited
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||