Vulnerability feed
CVE and vendor PSIRT advisories from 13 sources, last 30 days. Updated hourly, last run
| Expand | Severity |
Score |
Advisory |
Title |
Source |
Flags |
Published |
|---|---|---|---|---|---|---|---|
| High | 7.5 | CVE-2026-109936 |
The Otter Blocks WordPress plugin before 3.2.8 does not correctly bound a pattern it uses to rewrite its dynamic-content tokens while rendering blocks, so the pattern can...
Otter BlocksOtter Blocks
|
NVD | |||
|
CVE-2026-109936The Otter Blocks WordPress plugin before 3.2.8 does not correctly bound a pattern it uses to rewrite its dynamic-content tokens while rendering blocks, so the pattern can...
Executive summaryThe Otter Blocks WordPress plugin, before version 3.2.8, contains a cross-site scripting flaw that the advisory says is rated high severity with a CVSS score of 7.5. The fix is to update the plugin to version 3.2.8 or later. Technical summaryThe flaw is a cross-site scripting (CWE-79) caused by a regular expression pattern that is not correctly bounded when the plugin rewrites dynamic-content tokens while rendering blocks. The advisory's classification indicates the attacker needs at least Contributor-level access, but the advisory text itself does not explicitly state the attack vector or preconditions beyond the truncated description. Affected versions are stated as before 3.2.8, and the fixed version is 3.2.8. The advisory does not state any workaround, and it does not give detection guidance. Exploitation in the wild is not stated. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from wpscan.com/vulnerability/c9f264ad-0857-…1f-9f20-694469d7bee0 Impact if exploitedConfidentialityHigh IntegrityHigh AvailabilityHigh
How it is exploited
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||
| Medium | 5.3 | CVE-2026-109935 |
The Otter Blocks WordPress plugin before 3.2.8 does not enforce its block visibility conditions when a published post is rendered through the WordPress REST API, allowing...
Otter BlocksOtter Blocks
|
NVD | |||
|
CVE-2026-109935The Otter Blocks WordPress plugin before 3.2.8 does not enforce its block visibility conditions when a published post is rendered through the WordPress REST API, allowing...
Executive summaryThe Otter Blocks WordPress plugin, before version 3.2.8, fails to enforce its block visibility conditions when a published post is served through the WordPress REST API. The advisory classifies this as sensitive data disclosure with a CVSS score of 5.3 (medium), and the fix is to update the plugin to version 3.2.8. Technical summaryThe flaw is a sensitive data disclosure issue (CWE-200) in which block visibility conditions are not enforced when a published post is rendered through the WordPress REST API. The advisory describes the result as allowing access to content that should be hidden, but the rest of the text is truncated and does not state the exact attack prerequisites. The affected version range is stated as before 3.2.8, and the fixed version is 3.2.8. The CVSS score is 5.3 (medium) as listed. No workaround is stated, and no detection guidance is stated. Whether exploitation in the wild has been observed is not stated. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from wpscan.com/vulnerability/f19dbe9c-f172-…b8-8bfc-d21660aaa739 Impact if exploitedConfidentialityLow IntegrityNone AvailabilityNone
How it is exploited
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||
| Medium | 5.3 | CVE-2026-109934 |
The Otter Blocks WordPress plugin before 3.2.8 does not correctly determine whether a post is publicly readable before returning its data through a REST API endpoint, treating...
Otter BlocksOtter Blocks
|
NVD | |||
|
CVE-2026-109934The Otter Blocks WordPress plugin before 3.2.8 does not correctly determine whether a post is publicly readable before returning its data through a REST API endpoint, treating...
Executive summaryThe Otter Blocks WordPress plugin contains a flaw that can expose data from posts that are not publicly readable. The advisory classifies it as a sensitive data disclosure rated 5.3 (medium) under CVSS. The fix is to update the plugin to version 3.2.8 or later. Technical summaryThe flaw is a sensitive data disclosure (CWE-200) in which the plugin does not correctly check whether a post is publicly readable before returning its data through a REST API endpoint. The advisory describes the vulnerability as affecting versions before 3.2.8 and lists 3.2.8 as the fixed version. The attack vector, required privileges, and exact conditions for exploitation are not stated in the text provided. Workarounds are not stated. Detection guidance and any evidence of exploitation in the wild are not stated. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from wpscan.com/vulnerability/f634bde0-bfb0-…f9-9c85-fb72763c5dfd Impact if exploitedConfidentialityLow IntegrityNone AvailabilityNone
How it is exploited
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||
| Medium | 6.8 | CVE-2026-109933 |
The Otter Blocks WordPress plugin before 3.2.8 does not properly sanitize and escape user-supplied block styling values before writing them into an inline stylesheet, allowing...
Otter BlocksOtter Blocks
|
NVD | |||
|
CVE-2026-109933The Otter Blocks WordPress plugin before 3.2.8 does not properly sanitize and escape user-supplied block styling values before writing them into an inline stylesheet, allowing...
Executive summaryThe Otter Blocks WordPress plugin contains a cross-site scripting flaw that affects versions before 3.2.8. The advisory rates it medium severity with a CVSS score of 6.8 and recommends updating to version 3.2.8. Technical summaryThe flaw is a cross-site scripting (XSS) issue, CWE-79, caused by the plugin not properly sanitizing and escaping user-supplied block styling values before writing them into an inline stylesheet. The advisory's description is truncated after 'allowing...', so the exact attack vector and required privileges are not stated in the text provided. The fixed version is 3.2.8, and affected versions are described as before 3.2.8. No workaround is stated. No detection guidance is stated. The CVSS score is listed as 6.8 (medium), and the advisory does not state whether the vulnerability is exploited in the wild. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from wpscan.com/vulnerability/a2a19770-9ee2-…64-9ea6-a882cf0085e9 Impact if exploitedConfidentialityHigh IntegrityHigh AvailabilityHigh
How it is exploited
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||