Vulnerability feed
CVE and vendor PSIRT advisories from 13 sources, last 30 days. Updated hourly, last run
| Expand | Severity |
Score |
Advisory |
Title |
Source |
Flags |
Published |
|---|---|---|---|---|---|---|---|
| Medium | 5.4 | CVE-2026-90458 |
OpenStack Ironic before 39.0.1 allows DELETE and GET via vendor_passthru, e.g., to delete accounts from the BMC's Redfish service.
OpenStack, RedfishOpenStack Ironic
|
NVD | |||
|
CVE-2026-90458OpenStack Ironic before 39.0.1 allows DELETE and GET via vendor_passthru, e.g., to delete accounts from the BMC's Redfish service.
Executive summaryOpenStack Ironic, a bare metal server management service, contains a flaw that lets an authenticated user with vendor passthrough access send delete and read requests to arbitrary endpoints on a server's management controller (BMC) using the service's admin identity. The advisory does not state a numeric severity score, but the vendor tracker marks the related security advisory as Critical. The fix is an update to version 39.0.1 or a patched stable branch, and the advisory's fix validates subscription IDs. Technical summaryThe vulnerability is a path injection (path traversal) flaw in the Redfish vendor passthrough code, where an operator-supplied subscription ID is concatenated into a Redfish resource path without escaping. An authenticated caller with the baremetal:node:vendor_passthru permission can trigger arbitrary HTTP DELETE and GET requests on the BMC's Redfish root under the conductor's cached BMC-admin session. The advisory says vendor passthru requires SYSTEM_ADMIN, and the reviewer notes this is less risky on multi-tenant deployments. The advisory states the affected version as before 39.0.1, and the fix commits validate BMC subscription IDs on the affected stable and bugfix branches. The advisory does not state a CVSS score, a workaround, or exploitation in the wild, and it does not give detection guidance beyond the description of the impact. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from bugs.launchpad.net/ironic/+bug/2166507 Impact if exploitedConfidentialityLow IntegrityLow AvailabilityNone
How it is exploited
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||
| Medium | 5.0 | CVE-2026-89419 |
OpenStack Ironic before 39.0.1 sometimes allows a user to change the maintenance setting on a node via PATCH to /v1/nodes/{ident} - in other words, not using the specific...
OpenStackOpenStack Ironic
|
NVD | |||
|
CVE-2026-89419OpenStack Ironic before 39.0.1 sometimes allows a user to change the maintenance setting on a node via PATCH to /v1/nodes/{ident} - in other words, not using the specific...
Executive summaryOpenStack Ironic, a bare metal server management component, before version 39.0.1 lets a lessee project member change a node's maintenance setting through a PATCH request, bypassing the policy meant to restrict that action to lessee admins. The advisory does not state a severity rating or score, but the Launchpad bug was marked Critical by the maintainers. The vendor recommends applying the fixed Ironic releases, which the advisory lists as fix commits for master, stable/2026.2, stable/2026.1, stable/2025.2, stable/2025.1, unmaintained/2024.1, bugfix/38.0 and bugfix/37.0. Technical summaryThe flaw is a policy bypass (improper authorization) in the Ironic API PATCH handler for /v1/nodes/{ident}, where the per-field policy table omits the /maintenance and /maintenance_reason paths, so the generic baremetal:node:update rule is applied instead of the stricter set_maintenance and clear_maintenance rules. The attacker must be an authenticated Keystone user with the member role who is the project lessee of the node. The advisory names fixed versions only as fix branches (master, stable/2026.2, stable/2026.1, stable/2025.2, stable/2025.1, unmaintained/2024.1, bugfix/38.0, bugfix/37.0) and does not state specific fixed version numbers, though the title references 'before 39.0.1'. The advisory describes a regression test that can be added to the RBAC YAML tests, but the advisory does not state a workaround or any detection guidance. Exploitation in the wild is not stated. The CVSS score is not stated. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from bugs.launchpad.net/ironic/+bug/2166510 Impact if exploitedConfidentialityLow IntegrityLow AvailabilityLow
How it is exploited
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:L Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||
| Medium | 4.3 | CVE-2026-115638 |
OpenStack Ironic through 39.0.1 allows a denial of service via a configdrive that results in a very large amount of uncompressed data, aka a gzip bomb.
OpenStackOpenStack Ironic
|
NVD | |||
|
CVE-2026-115638OpenStack Ironic through 39.0.1 allows a denial of service via a configdrive that results in a very large amount of uncompressed data, aka a gzip bomb.
Executive summaryOpenStack Ironic, the bare-metal server provisioning service, is affected by a denial of service flaw. Any tenant allowed to deploy nodes can submit a specially crafted compressed configuration drive that expands to a very large size and can exhaust memory or disk on the conductor. The advisory does not state a severity score, and the fix has been merged to the master branch with backport changes proposed for several stable branches. Technical summaryThe flaw is a gzip bomb, a decompression denial of service, in the handling of base64-encoded gzip configdrive images supplied to Ironic node provision_state APIs by an authorized tenant. The conductor decompresses the image without a size limit, so a very small input can cause out-of-memory or out-of-disk conditions. The affected functions named are check_and_patch_configdrive in ironic/conductor/configdrive_utils.py and decode_and_extract_config_drive_iso in ironic/common/kickstart_utils.py. The fix, committed to master, chunks the decompression and enforces a 64MiB limit. Affected version ranges beyond the 'through 39.0.1' description are not clearly stated, and the fixed release version numbers are not stated. Backport reviews exist for stable/2026.2, stable/2026.1, stable/2025.2, bugfix/38.0, bugfix/37.0 and stable/2025.1, but the advisory does not say which releases contain the fix. No workaround beyond restricting tenant access is stated, and no detection guidance or exploitation in the wild is stated. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from bugs.launchpad.net/ironic/+bug/2171814 Impact if exploitedConfidentialityNone IntegrityNone AvailabilityLow
How it is exploited
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||