Vulnerability feed
CVE and vendor PSIRT advisories from 13 sources, last 30 days. Updated hourly, last run
| Expand | Severity |
Score |
Advisory |
Title |
Source |
Flags |
Published |
|---|---|---|---|---|---|---|---|
| Critical | 9.2 | CVE-2026-111497 |
A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker...
Google, Node.jsGoogle Brotli, Node.js
|
NVD | |||
|
CVE-2026-111497A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker...
Executive summaryThe advisory describes a buffer overflow in the Brotli decoder used by Google Brotli versions 1.0.3 through 1.2.0, and it also covers a set of Node.js security issues. The Node.js Project says the Brotli-related flaw in Node.js can allow remote code execution, and it rates the highest fixed Node.js issues as high severity. The recommended action is to upgrade to the fixed Node.js releases named in the advisory, namely v22.23.4, v24.22.1, or v26.12.1. Technical summaryThe Brotli flaw is a buffer overflow in c/dec/decode.c, and the advisory says a remote unauthenticated attacker can exploit it, though the rest of that sentence is cut off, so the full attack conditions are not stated. In the Node.js issue, malformed Brotli input causes an invalid block switch to be treated as needing more input, so the decoder keeps writing into an eight-byte buffer, which the advisory says can lead to crash, memory disclosure, or remote code execution. The Node.js advisory names fixed versions v22.23.4, v24.22.1, and v26.12.1, and states that the 22.x, 24.x, and 26.x lines are affected. The advisory does not state a workaround, and it does not give a Brotli fixed version or any detection guidance for the Brotli issue. Exploitation in the wild is not stated. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from nodejs.org/en/blog/vulnerability/octobe…e-2026-111497---high Impact if exploitedConfidentialityHigh IntegrityHigh AvailabilityHigh
How it is exploited
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||
| High | 8.1 | CVE-2026-111497 |
Google: CVE-2026-111497 Buffer overflow vulnerability in the Brotli decoder
Microsoft, GoogleMicrosoft .NET, Google Brotli
|
Microsoft MSRC | |||
|
CVE-2026-111497Google: CVE-2026-111497 Buffer overflow vulnerability in the Brotli decoder
Executive summaryA buffer overflow in the Brotli decoder can let an unauthorized attacker elevate privileges over a network. The advisory does not state a severity rating or a CVSS score, and it does not name a fixed version or a vendor recommendation. Technical summaryThe flaw is described as a buffer overflow caused by an out-of-bounds write in .NET, the Brotli decoder component. The advisory states that an unauthorized attacker can exploit it over a network to elevate privileges. Affected and fixed version numbers are not stated. Required user interaction, authentication details, and exploitation status are not stated. No workaround or detection guidance is provided. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Impact if exploitedConfidentialityHigh IntegrityHigh AvailabilityHigh
How it is exploited
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:U/RL:O/RC:C Affects
Microsoft Security Response CenterPublished
Read the advisory
|
|||||||