Vulnerability feed
CVE and vendor PSIRT advisories from 13 sources, last 30 days. Updated hourly, last run
| Expand | Severity |
Score |
Advisory |
Title |
Source |
Flags |
Published |
|---|---|---|---|---|---|---|---|
| High | 7.1 | CVE-2026-114178 |
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Bold Grid W3 Total Cache w3-total-cache allows Stored XSS.This issue...
Bold GridBold Grid W3 Total Cache
|
NVD | |||
|
CVE-2026-114178Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Bold Grid W3 Total Cache w3-total-cache allows Stored XSS.This issue...
Executive summaryA cross-site scripting flaw affects the W3 Total Cache WordPress plugin by Bold Grid, in versions up to and including 2.10.7. The advisory rates it as medium priority with a CVSS severity of 7.1 and says attackers could inject scripts that steal visitor data or hijack accounts. The recommended fix is to update the plugin to version 2.11.0 or later. Technical summaryThe flaw is a stored cross-site scripting (XSS) issue classified under OWASP A3: Injection, caused by improper neutralization of input during web page generation. The advisory lists the required privilege as unauthenticated, but says exploitation requires a privileged user to take an action such as clicking a malicious link, visiting a crafted page, or submitting a form. Vulnerable versions are stated as <= 2.10.7 and the patched version as 2.11.0. Patchstack has issued a mitigation rule that blocks attacks until the site is updated, and it recommends updating to 2.11.0 or later. The advisory does not state any further workarounds or specific detection guidance beyond this. Summaries are generated by AI from the linked advisory text. Confirm versions and fixes at the source. Summarized from patchstack.com/database/wordpress/plugi…nerability?_s_id=cve Impact if exploitedConfidentialityLow IntegrityLow AvailabilityLow
How it is exploited
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||
| High | 7.2 | CVE-2026-87920 |
The W3 Total Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment Content via Output-Buffer Regex Rewrite in all versions up to, and including,...
Bold GridBold Grid W3 Total Cache
|
NVD | |||
|
CVE-2026-87920The W3 Total Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment Content via Output-Buffer Regex Rewrite in all versions up to, and including,...
From the advisoryThe W3 Total Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment Content via Output-Buffer Regex Rewrite in all versions up to, and including, 2.10.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This vulnerability is only exploitable when the 'Remove query strings from static resources' option is enabled in W3 Total Cache, as mutate_url() must strip the '?' delimiter and everything following it — including the closing quote of the outer attribute — to break the attribute boundary. Impact if exploitedConfidentialityLow IntegrityLow AvailabilityNone
How it is exploited
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N Affects
NIST National Vulnerability DatabasePublished
Read the advisory
|
|||||||